Supported iPhones

Requires iOS 12.0 or later

Device Supported?
iPhone XR
iPhone XS Max
iPhone XS
iPhone X
iPhone 8 Plus
iPhone 8
iPhone 7 Plus
iPhone 7
iPhone SE
iPhone 6s Plus
Compatible with iPhone 6s

We use cookies and analytics to improve our service and give our users a better experience on our website.
Click here for more information.